# Abstract

The Hydrologic Modeling System (HEC-HMS) is designed to simulate the complete hydrologic processes of dendritic watershed systems. It includes many traditional hydrologic analysis procedures such as event infiltration, unit hydrographs, and hydrologic routing. It also includes procedures necessary for continuous simulation including evapo-transpiration, snowmelt, and soil moisture accounting. Gridded runoff simulation can also be performed. Supplemental analysis tools are provided for parameter estimation, depth-area analysis, flow forecasting, uncertainty assessment, erosion and sediment transport, and nutrient water quality.

The program features an integrated work environment with data entry utilities, computation engine, and results reporting tools. A graphical user interface allows seamless movement between the different parts of the program. Simulation results are stored in the Data Storage System HEC-DSS and can be used in conjunction with other software for studies of water availability, urban drainage, flow forecasting, future urbanization impact, reservoir spillway design, flood damage reduction, floodplain regulation, and systems operation.

**Subject Terms**

Hydrology, watershed, precipitation runoff, river routing, flood frequency, flood control, water supply, computer simulation, environmental restoration.
Hydrologic Modeling System
HEC-HMS

Quick Start Guide

Version 4.1
July 2015

US Army Corps of Engineers
Institute for Water Resources
Hydrologic Engineering Center
609 Second Street
Davis, CA 95616 USA

Phone 530.756.1104
Fax 530.756.8250
Email hec.hms@usace.army.mil
Hydrologic Modeling System HEC-HMS, Quick Start Guide

2015. This Hydrologic Engineering Center (HEC) Manual is a U.S. Government document and is not subject to copyright. It may be copied and used free of charge. Please acknowledge the U.S. Army Corps of Engineers Hydrologic Engineering Center as the author of this Manual in any subsequent use of this work or excerpts.

Use of the software described by this document is controlled by certain terms and conditions. The user must acknowledge and agree to be bound by the terms and conditions of usage before the software can be installed or used. For reference, a copy of the terms and conditions of usage are included in the User’s Manual.

Please recycle this document when you are finished using it.
# Table of Contents

INTRODUCTION .................................................................................................................... 1  
MODEL COMPONENTS........................................................................................................... 1  
   Basin Model Component .......................................................................................... 2  
   Meteorologic Model Component ............................................................................. 5  
   Control Specifications Component ........................................................................... 6  
   Input Data Components ........................................................................................... 6  
USER INTERFACE ............................................................................................................. 7  
   Watershed Explorer ................................................................................................. 8  
   Component Editor ..................................................................................................... 9  
   Message Log ............................................................................................................ 10  
   Desktop .................................................................................................................. 10  
DOCUMENTATION CONVENTIONS .............................................................................. 11  
REFERENCES ................................................................................................................. 11  
DEVELOPING A HEC-HMS PROJECT .............................................................................. 12  
   CREATE A NEW PROJECT ..................................................................................... 12  
   INPUT DATA ............................................................................................................. 13  
   CREATE A BASIN MODEL ....................................................................................... 15  
   CREATE A METEOROLOGIC MODEL .................................................................... 17  
   DEFINE CONTROL SPECIFICATIONS .................................................................... 18  
   CREATE AND COMPUTE A SIMULATION RUN .......... .................................................. 19  
   VIEW MODEL RESULTS .......................................................................................... 20  
EXAMPLE ............................................................................................................................. 24  
   PROBLEM STATEMENT .......................................................................................... 24  
   CREATE THE PROJECT .......................................................................................... 27  
   INPUT DATA ............................................................................................................. 28  
   CREATE THE BASIN MODEL .................................................................................. 30  
      Create the Element Network ................................................................................ 30  
      Enter Element Data ............................................................................................ 32  
   CREATE THE METEOROLOGIC MODEL ................................................................ 37  
   DEFINE CONTROL SPECIFICATIONS .................................................................. 40  
   CREATE AND COMPUTE A SIMULATION RUN ..................................................... 40  
   VIEW MODEL RESULTS .......................................................................................... 41  
   SIMULATE FUTURE URBANIZATION ..................................................................... 44  
      Create the Modified Basin Model ....................................................................... 44  
      Urbanized Simulation Run ................................................................................. 45  
APPENDIX ........................................................................................................................... 48  
   CREATE AND COMPUTE AN OPTIMIZATION TRIAL ............................................. 48  
   CREATE AND COMPUTE A DEPTH-AREA ANALYSIS ............................................. 51
Chapter 1

Introduction

This document was developed using the Hydrologic Engineering Center's Hydrologic Modeling System (HEC-HMS) Version 4.0.

HEC-HMS is designed to simulate the precipitation-runoff processes of dendritic watershed systems. It is designed to be applicable in a wide range of geographic areas for solving a broad range of problems. This includes large river basin water supply and flood hydrology to small urban or natural watershed runoff. Hydrographs produced by the program can be used directly or in conjunction with other software for studies of water availability, urban drainage, flow forecasting, future urbanization impact, reservoir spillway design, flood damage reduction, floodplain regulation, wetlands hydrology, and systems operation.

This document was written as a brief introduction to the program and will be more beneficial to users with experience using previous versions of HEC-HMS. For less experienced users, a more comprehensive description and application of the program can be found in the HEC-HMS User's Manual, HEC-HMS Technical Reference Manual, and the HEC-HMS Applications Guide. The Quick Start Guide is divided into the following three chapters: Chapter 1 provides a description of program components and the user interface, Chapter 2 lists and describes steps required to develop a hydrologic model and obtain results, and Chapter 3 contains an example application following the steps outlined in Chapter 2. An appendix is included to provide a description of the optimization and the depth-area analysis features.

Model Components

Model components are used to simulate the hydrologic response in a watershed. The primary model components are basin models, meteorologic models, and control specifications. There are also input data components. A simulation calculates the precipitation-runoff response in the basin model given input from the meteorologic model. The control specifications define the time period and time step of the simulation run. Input data components, such as time-series data, paired data, and gridded data are often required as parameter or boundary conditions in basin and meteorologic models.
**Basin Model Component**

The basin model represents the physical watershed. The user develops a basin model by adding and connecting hydrologic elements. Hydrologic elements use mathematical models to describe physical processes in the watershed. Table 1 provides a list and description of available hydrologic elements.

<table>
<thead>
<tr>
<th>Hydrologic Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Subbasin</strong></td>
<td>The subbasin element is used to represent the physical watershed. Given precipitation, outflow from the subbasin element is calculated by subtracting precipitation losses, transforming excess precipitation to stream flow at the subbasin outlet, and adding baseflow.</td>
</tr>
<tr>
<td><strong>Reach</strong></td>
<td>The reach element is used to convey stream flow downstream in the basin model. Inflow into the reach element can come from one or many upstream hydrologic elements. Outflow from the reach is calculated by accounting for translation and attenuation of the inflow hydrograph.</td>
</tr>
<tr>
<td><strong>Junction</strong></td>
<td>The junction element is used to combine stream flow from hydrologic elements located upstream of the junction element. Inflow into the junction element can come from one or many upstream elements. Outflow is simply calculated by summing all inflows and assuming no storage at the junction.</td>
</tr>
<tr>
<td><strong>Source</strong></td>
<td>The source element is used to introduce flow into the basin model. The source element has no inflow. Outflow from the source element is defined by the user.</td>
</tr>
<tr>
<td><strong>Sink</strong></td>
<td>The sink element is used to represent the outlet of the physical watershed. Inflow into the sink element can come from one or many upstream hydrologic elements. There is no outflow from the sink element.</td>
</tr>
</tbody>
</table>
Table 1 cont’d. Hydrologic element description.

<table>
<thead>
<tr>
<th>Hydrologic Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reservoir</td>
<td>The reservoir element is used to model the detention and attenuation of a hydrograph caused by a reservoir or detention pond. Inflow into the reservoir element can come from one or many upstream hydrologic elements. Outflow from the reservoir element can be calculated three ways. The user can enter a storage-outflow, elevation-storage-outflow, or elevation-area-outflow relationship, or the user can enter an elevation-storage or elevation-area relationship and define one or more outlet structures, or the user can specify a time-series of outflow.</td>
</tr>
<tr>
<td>Diversion</td>
<td>The diversion element is used for modeling stream flow leaving the main channel. Inflow into the diversion element can come from one or many upstream hydrologic elements. Outflow from the diversion element consists of diverted flow and non-diverted flow. Diverted flow is calculated using input from the user. Both diverted and non-diverted flows can be connected to hydrologic elements downstream of the diversion element.</td>
</tr>
</tbody>
</table>

In the case of the subbasin element, many mathematical models are available for determining precipitation losses, transforming excess precipitation to stream flow at the subbasin outlet, and adding baseflow. In this document the different mathematical models will be referred to as methods. Table 2 lists the methods available for subbasin and river reach elements.
Table 2.  **Subbasin and reach calculation methods.**

<table>
<thead>
<tr>
<th>Hydrologic Element Type</th>
<th>Calculation Type</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subbasin</td>
<td>Canopy</td>
<td>Dynamic Canopy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Simple Canopy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gridded Simple Canopy</td>
</tr>
<tr>
<td>Surface</td>
<td>Simple Surface</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gridded Simple Surface</td>
</tr>
<tr>
<td>Runoff-volume</td>
<td>Deficit and constant rate (DC)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Exponential</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Green and Ampt</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gridded DC</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gridded SCS CN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gridded Green and Ampt</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gridded SMA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Initial and constant rate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SCS curve number (CN)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Smith Parlange</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Soil moisture accounting (SMA)</td>
</tr>
<tr>
<td>Direct-runoff</td>
<td>Clark’s UH</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Kinematic wave</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ModClark</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SCS UH</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Snyder’s UH</td>
<td></td>
</tr>
<tr>
<td></td>
<td>User-specified s-graph</td>
<td></td>
</tr>
<tr>
<td></td>
<td>User-specified unit hydrograph (UH)</td>
<td></td>
</tr>
<tr>
<td>Baseflow</td>
<td>Bounded recession</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Constant monthly</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Linear reservoir</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Nonlinear Boussinesq</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Recession</td>
<td></td>
</tr>
</tbody>
</table>
Table 2 cont’d. Subbasin and reach calculation methods.

<table>
<thead>
<tr>
<th>Hydrologic Element Type</th>
<th>Calculation Type</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reach</td>
<td>Routing</td>
<td>Kinematic wave</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Lag</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Modified Puls</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Muskingum</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Muskingum-Cunge</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Straddle Stagger</td>
</tr>
<tr>
<td>Loss/Gain</td>
<td>Constant</td>
<td>Percolation</td>
</tr>
</tbody>
</table>

**Meteorologic Model Component**

The meteorologic model calculates the precipitation input required by a subbasin element. The meteorologic model can utilize both point and gridded precipitation and has the capability to model frozen and liquid precipitation along with evapotranspiration. The meteorologic model includes multiple snowmelt and evapotranspiration methods. The snowmelt methods include a temperature index algorithm and an energy balance approach to calculate the accumulation and melt of the snow pack. The evapotranspiration methods include the monthly average, Priestly Taylor, Penman Monteith, and user specified time-series methods. An evapotranspiration method is only required when simulating the continuous or long term hydrologic response in a watershed. Shortwave and longwave radiation methods are also included in the meteorologic model for developing input data for the snowmelt and evapotranspiration models. A brief description of the methods available for calculating basin average precipitation or grid cell precipitation is included in Table 3.
Table 3. Description of meteorologic model methods.

<table>
<thead>
<tr>
<th>Precipitation Methods</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frequency Storm</td>
<td>This method is used to develop a precipitation event where precipitation depths for various durations within the storm have a consistent exceedance probability.</td>
</tr>
<tr>
<td>Gage Weights</td>
<td>This method applies user specified weights to user defined precipitation gages.</td>
</tr>
<tr>
<td>Gridded Precipitation</td>
<td>This method allows the use of gridded precipitation products, such as RADAR.</td>
</tr>
<tr>
<td>Inverse Distance</td>
<td>This method calculates subbasin average precipitation by applying an inverse distance squared weighting to user defined precipitation gages.</td>
</tr>
<tr>
<td>SCS Storm</td>
<td>This method applies a user specified SCS time distribution to a 24-hour total storm depth.</td>
</tr>
<tr>
<td>Specified Hyetograph</td>
<td>This method applies a user defined hyetograph to a specified subbasin element.</td>
</tr>
<tr>
<td>Standard Project Storm</td>
<td>This method applies a time distribution to an index precipitation depth.</td>
</tr>
<tr>
<td>HMR 52</td>
<td>This method is used to develop a PMP storm according to NOAA’s HMR 52.</td>
</tr>
</tbody>
</table>

Control Specifications Component

The control specifications set the time span of a simulation run. Information in the control specifications includes a starting date and time, ending date and time, and computation time step.

Input Data Components

Time-series data, paired data, and gridded data are often required as parameter or boundary conditions in basin and meteorologic models. A complete list of input data is included in Table 4. Input data can be entered manually or referenced to an existing record in a HEC-DSS file. All gridded data must be referenced to an existing HEC-DSS record. Refer to the HEC-DSSVue User’s Manual (USACE, 2009) for a description of HEC-DSS.
Table 4.  Input data components.

<table>
<thead>
<tr>
<th>Time-Series Data</th>
<th>Paired Data</th>
<th>Gridded Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Precipitation</td>
<td>Storage-discharge</td>
<td>Precipitation</td>
</tr>
<tr>
<td>Discharge</td>
<td>Elevation-storage</td>
<td>Temperature</td>
</tr>
<tr>
<td>Stage</td>
<td>Elevation-area</td>
<td>Radiation</td>
</tr>
<tr>
<td>Temperature</td>
<td>Elevation-discharge</td>
<td>Crop coefficient</td>
</tr>
<tr>
<td>Radiation</td>
<td>Inflow-diversion</td>
<td>Storage capacity</td>
</tr>
<tr>
<td>Windspeed</td>
<td>Diameter-Percentage</td>
<td>Percolation rate</td>
</tr>
<tr>
<td>Air Pressure</td>
<td>Cross sections</td>
<td>Storage coefficients</td>
</tr>
<tr>
<td>Humidity</td>
<td>Unit hydrograph</td>
<td>Moisture deficit</td>
</tr>
<tr>
<td>Altitude</td>
<td>Percentage</td>
<td>Impervious area</td>
</tr>
<tr>
<td>Crop coefficient</td>
<td>Duration-Precipitation</td>
<td>SCS curve number</td>
</tr>
<tr>
<td>Snow water equivalent</td>
<td>ATI-meltrate</td>
<td>Elevation</td>
</tr>
<tr>
<td>Sediment Load</td>
<td>ATI-coldrate</td>
<td>Cold content</td>
</tr>
<tr>
<td>Concentration</td>
<td>Groundmelt</td>
<td>Cold content ATI</td>
</tr>
<tr>
<td>Percent</td>
<td>Percent</td>
<td>Meltrate ATI</td>
</tr>
<tr>
<td>Evapotranspiration</td>
<td>Cumulative Probability</td>
<td>Liquid water content</td>
</tr>
<tr>
<td>Sunshine</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**User Interface**

The user interface consists of a menu bar, tool bar, and four main panes. Starting from the upper left pane in Figure 1 and moving counter-clockwise, these panes will be referred to as the Watershed Explorer, the Component Editor, the Message Log, and the Desktop.
Chapter 1 Introduction

Figure 1. HEC-HMS user interface.

Watershed Explorer

The Watershed Explorer was developed to provide quick access to all components in an HEC-HMS project. For example, the user can easily navigate from a basin model to a precipitation gage and then to a meteorologic model without using menu options or opening additional windows. The Watershed Explorer is divided into three parts: Components, Compute, and Results. The arrow in Figure 2 points to the “Components” tab of the Watershed Explorer. The hierarchal structure of model components, such as basin models, meteorologic models, etc., is available from the “Components” tab of the Watershed Explorer. The Watershed Explorer organizes model components into individual folders. When a component is selected, the Watershed Explorer expands to show sub-components. For example, when a basin model is selected the Watershed Explorer will expand to show all hydrologic elements in the basin model. Notice in Figure 2 that the Castro 1 basin model is selected and the Watershed Explorer is expanded to show all hydrologic elements in the basin model. The plus/minus sign beside model components and sub-components can be used to expand/collapse the Watershed Explorer. All project simulation runs, optimization trials, and analyses are accessed from the “Compute” tab of the Watershed Explorer. Model results are available from the “Results” tab of Watershed
Explorer. Results from different simulations can be compared in the same graph or table.

Figure 2. Watershed Explorer showing components in the project.

Component Editor

When a component or sub-component in the Watershed Explorer is active (simply use the mouse and click on the component name in the Watershed Explorer), a specific Component Editor will open. All data that can be specified in the model component is entered in the Component Editor. Any required data will be indicated with a red asterisk. For example, parameter data for the SCS curve number method is entered in the Component Editor for a subbasin element. The Component Editor for the Castro 1 basin model is shown in Figure 3.
Figure 3. Component editor for a basin model.

Message Log

Notes, warnings, and errors are shown in the Message Log (Figure 4). These messages are useful for identifying why a simulation run failed or why a requested action, like opening a project, was not completed.

Figure 4. Message log.

Desktop

The Desktop holds a variety of windows including summary tables, time-series tables, graphs, global editors, and the basin model map. Results are not confined to the desktop area. A program settings option will allow results to be displayed outside the desktop area. The basin model map is confined to the Desktop. The basin model map is used to develop a basin model. Elements (subbasin, river reach, reservoir, etc.) are added from the toolbar and connected to represent the physical drainage network of the study area. Background maps can be imported to help visualize the watershed. The Castro 1 basin model map is shown in Figure 5.
Documentation Conventions

The following conventions are used throughout the Quick Start Guide to describe the program interface.

- Screen titles are shown in italics.
- Menu names, menu items, component and subcomponent names in the Watershed Explorer, and button names are shown in bold.
- Menus are separated from submenus with the right arrow ⇒.
- Data to be typed into an input field on a screen is shown in the courier font.
- A column heading, tab name, or field title is shown in “double quotes”.

References

Developing a HEC-HMS Project

To develop a hydrologic model, the user must complete the following steps:

- Create a new project.
- Input time series, paired, and gridded data needed by the basin or meteorologic model.
- Define the physical characteristics of the watershed by creating and editing a basin model.
- Select a method for calculating subbasin precipitation and enter required information. Evapotranspiration and snow melt information are also entered at this step if required.
- Define the control specifications.
- Combine a basin model, meteorologic model, and control specifications to create a simulation.
- View the results and modify the basin model, meteorologic model, or control specifications as needed.

Create a New Project

Create a new project by selecting **File** ⇒ **New...** from the menu bar (Figure 6). Enter a project “Name,” enter a project “Description,” select a “Location” for storing project files, and choose the “Default Unit System” in the **Create a New Project** screen (Figure 7). A new folder with the same name as the project name is created in the selected directory. This folder will store all files created for this project. External HEC-DSS files, ModClark files, and background map files do not have to be stored in the project folder. A new project can also be created by selecting the **Create a New Project** button on the tool bar.

Options for managing a project are available from the **File** menu option. These options include **Open...**, **Save**, **Save As...**, **Delete**, and **Rename**. The tool bar contains buttons to open a project and save the current project.
Figure 6. Create a new project.

Figure 7. Enter a project name, a project description, location of project files, and the default unit system.

Input Data

Time series data, paired data, and gridded data are created using component managers. Component managers are opened from the Components menu by selecting the Time-Series Data Manager, Paired Data Manager, or Grid Data Manager menu options (Figure 8). At the top of these managers is an option that allows the user to select the gage, paired data, or grid data type. Buttons on the right side of the manager provide options to create a New..., Copy..., Rename..., or Delete the data type. Figure 9 shows the Paired Data Manager (the Storage-Discharge data type is selected). Once a new input data type has been created, required information can be entered in the Component Editor. Input data can be entered manually or referenced to an existing record in a HEC-DSS file.
Figure 8. **Input data managers.**

![Input data managers](image)

Figure 9. **Paired data manager.**

![Paired data manager](image)

Figure 10 shows the Component Editor for a storage-discharge function. Open the Component Editor by clicking on the paired data function in the Watershed Explorer. The table can be renamed in the Watershed Explorer or in the Paired Data Manager. The “Data Source” options are Manual Entry and Data Storage System (HEC-DSS). If Data Storage System (HEC-DSS) is selected, the user is required to select a HEC-DSS file and a pathname. If Manual Entry is selected, the user must click the “Table” tab and manually enter the storage-discharge curve.

A time window is required before time-series data can be entered or viewed. A default time window is provided when a time-series gage is added to the project. To add an additional time window, click the right mouse button when the mouse is on top of the gage’s name in the
**Watershed Explorer.** Select the **Create Time Window** option in the popup menu (Figure 11).

![Component editor for a storage-discharge function.](image)

**Figure 10.** Component editor for a storage-discharge function.

**Create a Basin Model**

A new basin model can be added to a project by selecting the **Components ⇒ Basin Model Manager** menu option (Figure 12). Click the **New...** button in the Basin Model Manager window. Enter a “Name” and “Description” in the **Create A New Basin Model** window and click the **Create** button (Figure 13). An existing basin model can be added to the opened HEC-HMS project by selecting the **File ⇒ Import ⇒ Basin Model...** menu option.

![Open the basin model manager.](image)

**Figure 12.** Open the basin model manager.
Chapter 2 Developing a HEC-HMS Project

Figure 13. Create a new basin model.

Once a new basin model has been added, hydrologic elements can be added and connected in the basin model map to reflect the drainage of the real world watershed. To open the basin model map in the Desktop, select the basin model in the Watershed Explorer, “Components” tab. Hydrologic elements are added by selecting one of the element tools on the tool bar (Figure 14) and clicking the left mouse button in the basin model map. To connect an upstream element to a downstream element, place the mouse on top of the upstream element icon and click the right mouse button. Select the Connect Downstream option from the popup menu. Then place the mouse on top of the desired downstream element icon and click the left mouse button.

Create Copy..., Rename..., or Delete the basin model by clicking the right mouse button when the mouse is located on top of the basin model name in the Watershed Explorer. These options are also available from the Basin Model Manager. Similar menu options are available for managing hydrologic elements when using the right mouse button inside the Watershed Explorer. The Copy Element and Delete Element options are also available in the basin model map. Move the mouse on top of one of the hydrologic element icons and click the right mouse button to open a popup menu containing these options.

Basin model and hydrologic element parameter data are entered in the Component Editor. Select a basin model name or hydrologic element name in the Watershed Explorer to open the Component Editor. The Component Editor for a hydrologic element can also be opened by selecting the element icon in the basin model map. Figure 15 shows a
Component Editor for a subbasin element. Notice the five tabs labeled “Subbasin,” “Loss,” “Transform,” “Baseflow,” and “Options.”

Figure 14. Hydrologic element tools.

Component Editor for a subbasin element.

Create a Meteorologic Model

A meteorologic model is added to a project in the same manner as the basin model. Select the Components ⇒ Meteorologic Model Manager menu option. Click the New… button in the Meteorologic Model Manager window and enter a “Name” and “Description” in the Create A New Meteorologic Model window. To import an existing meteorologic model, select the File ⇒ Import ⇒ Meteorologic Model… menu option. The meteorologic model can be renamed in the Watershed Explorer or from the Meteorologic Model Manager. Figure 16 shows the Component Editor for a meteorologic model.

One step in developing a meteorologic model is to define which basin models require precipitation from the meteorologic model. Open the Component Editor for the meteorologic model by selecting it in the
Watershed Explorer, “Components” tab. Select the “Basins” tab and change the “Include Subbasins” option to “Yes” for all basin models requiring precipitation from the selected meteorologic model (Figure 17). All subbasin elements contained in the selected basin model(s) will be added to the meteorologic model. Once added, parameters for the precipitation, evapotranspiration, and snowmelt methods can be defined for each subbasin element using the Component Editor.

![Figure 16. Component editor for a meteorologic model.](image)

![Figure 17. Adding subbasin elements to a meteorologic model.](image)

**Define Control Specifications**

A control specifications is added to a project by selecting the Components ⇒ Control Specifications Manager menu option. Click the New... button in the Control Specifications Manager window and enter a “Name” and “Description” in the Create A New Control Specifications window. The Component Editor (Figure 18) for a control specifications requires a start date and time, an end date and time, and a time step. Start and end dates must be entered using the “ddMMMYYYY” format, where “d” represents the day, “M” represents the month, and “Y” represents the year. Time is entered using the 24 hour format. Start and end times must be entered using the “HH:mm” format, where “H” represents the hour and “m” represents the minute. The time step is selected from an available interval list containing time steps from 1 minute...
to 24 hours. Calculations for most methods are performed using the specified time step; output is always reported in the specified time step.

![Control Specifications](image)

Figure 18. Control specifications.

Create and Compute a Simulation Run

A simulation run is created by selecting the **Compute ⇒ Run Manager** menu option. Click the **New...** button in the *Simulation Run Manager* window. The simulation run manager also allows the user to **Copy...**, **Rename...**, and **Delete** an existing simulation run. After clicking the **New...** button, a wizard opens to step the user through the process of creating a simulation run. First, a name must be entered for the simulation run, then a basin model, a meteorologic model, and a control specifications must be selected. The new simulation run is added to the “Compute” tab of the *Watershed Explorer* (Figure 19). Notice the “Compute” tab of the *Watershed Explorer* contains a separate folder for each simulation type: simulation runs, optimization trials, and analyses. The *Watershed Explorer* expands to show all simulation runs in the project when the “Simulation Runs” folder is selected. A simulation run can also be created by selecting the **Compute ⇒ Create Simulation Run** menu option. In the *Component Editor* for a simulation run, the user can enter a “Description” and change the basin model, meteorologic model, and control specifications from drop-down lists (Figure 19).

The simulation run can be renamed in the *Watershed Explorer* or from the *Simulation Run Manager*. Click the right mouse button when the mouse is located on top of the simulation run’s name in the *Watershed Explorer* and select the **Rename...** option. Other options available when clicking the right mouse button include **Compute**, **Create Copy...**, **Rename**, and **Delete**. The **Compute** toolbar can also be used to compute a simulation run. First, the simulation run must be selected from a list of current simulation runs (Figure 20). To compute the selected simulation run, press the compute current run button (Figure 21).
View Model Results

Graphical and tabular results are available after a simulation run, an optimization trial, and an analysis have been computed (refer to the appendix for a description of optimization trials and analyses). Results can be accessed from the Watershed Explorer or the basin model map. Results are available as long as no edits were made to model components (subbasin parameters, time-series data, etc.) after the simulation run, optimization trial, or analysis were computed. If edits were made, the simulation run, optimization trial, or analysis must be re-computed.

Select the “Results” tab of the Watershed Explorer to view a list of simulation runs, optimization trials, and analyses (Figure 22). Click the box next to the name of the simulation run, optimization trial, or analysis to expand the Watershed Explorer. Click the box next to a hydrologic...
element’s name to expand the Watershed Explorer even more to show available results for the hydrologic element. When a times series result is selected in the Watershed Explorer, a preview graph opens in the Component Editor. Figure 22 shows a times series graph for a subbasin element (Subbasin-2). Multiple time series records can be added to the same graph by holding the Control key and clicking other time series results. Time series results from different basin model elements and from different simulation runs and optimization trials can be added to the same graph for comparison (Figure 23). A copy of the preview graph will open by clicking the graph button on the toolbar (Figure 23).

Results can also be accessed from the basin model map. After a simulation run computes, move the mouse on top of a basin model element and click the right mouse button. In the popup menu, select the View Results option and choose Graph, Summary Table, or Time-Series Table (Figure 24). Results can also be accessed from the Compute toolbar. Select a basin model element in the basin model map or Watershed Explorer to make it active. Then choose the graph, summary table, or times-series table button on the toolbar.
Figure 22. Viewing results.
Chapter 2 Developing an HEC-HMS Project

Figure 23. Comparing results from different simulation runs.

Figure 24. Accessing results from the basin model map.
Chapter 3 Example

Example

This chapter illustrates the steps necessary to create a precipitation-runoff model with an example.

Problem Statement

This example uses data from the 5.51 square mile Castro Valley watershed located in northern California. The watershed contains four major catchments (Figure 25). Precipitation data for a storm that occurred on January 16, 1973, is available for three gages in the watershed: Proctor School, Sidney School, and Fire Department. The goal of the example is to estimate the affect of proposed future urbanization on the hydrologic response.

![Castro Valley Creek watershed](image)

Figure 25. Castro Valley Creek watershed.

Application of the program will require creating a new project and entering gage data. A basin model using the initial constant loss, Snyder unit hydrograph transform, and recession baseflow methods will be created from the parameter data shown in Tables 5 - 8.
Table 5. Subbasin initial and constant loss method and Snyder transform method data.

<table>
<thead>
<tr>
<th>Subbasin ID</th>
<th>Loss Parameters</th>
<th>Transform Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Initial in</td>
<td>Constant in/hr</td>
</tr>
<tr>
<td>1</td>
<td>0.02</td>
<td>0.14</td>
</tr>
<tr>
<td>2</td>
<td>0.02</td>
<td>0.14</td>
</tr>
<tr>
<td>3</td>
<td>0.02</td>
<td>0.14</td>
</tr>
<tr>
<td>4</td>
<td>0.02</td>
<td>0.14</td>
</tr>
</tbody>
</table>

Table 6. Subbasin area and baseflow data.

<table>
<thead>
<tr>
<th>Subbasin Parameters</th>
<th>Baseflow Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Area sq-mi</td>
</tr>
<tr>
<td>1</td>
<td>0.86</td>
</tr>
<tr>
<td>2</td>
<td>1.52</td>
</tr>
<tr>
<td>3</td>
<td>2.17</td>
</tr>
<tr>
<td>4</td>
<td>0.96</td>
</tr>
</tbody>
</table>

Table 7. Routing criteria for reaches.

<table>
<thead>
<tr>
<th>ID</th>
<th>From Subbasin</th>
<th>To Subbasin</th>
<th>Method</th>
<th>Sub-reaches</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reac h-2</td>
<td>Subbasin-1</td>
<td>East Branch</td>
<td>Muskingum</td>
<td>7</td>
<td>K = 0.6 hr, x = 0.2</td>
</tr>
<tr>
<td>Reac h-1</td>
<td>Subbasin-3</td>
<td>West Branch</td>
<td>Modified Puls</td>
<td>4</td>
<td>in = out, Table 8</td>
</tr>
</tbody>
</table>
Table 8. Storage-discharge data for Reach 2.

<table>
<thead>
<tr>
<th>Storage ac-ft</th>
<th>Outflow cfs</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0.2</td>
<td>2</td>
</tr>
<tr>
<td>0.5</td>
<td>10</td>
</tr>
<tr>
<td>0.8</td>
<td>20</td>
</tr>
<tr>
<td>1.0</td>
<td>30</td>
</tr>
<tr>
<td>1.5</td>
<td>50</td>
</tr>
<tr>
<td>2.7</td>
<td>80</td>
</tr>
<tr>
<td>4.5</td>
<td>120</td>
</tr>
<tr>
<td>750</td>
<td>1,500</td>
</tr>
<tr>
<td>5,000</td>
<td>3,000</td>
</tr>
</tbody>
</table>

A meteorologic model will have to be created for the precipitation data. Thiessen polygon weights (Table 9) will be used for the user gage weighting precipitation method. Total rainfall measured by the Proctor School and Sidney School gages was 1.92 and 1.37 inches, respectively. Storm rainfall is to be distributed in time using the temporal pattern of incremental precipitation from the Fire Department gage. The Fire Department gage data has been stored in the HEC-DSS file named CASTRO.DSS with the following pathname:/CASTRO VALLEY/FIRE DEPT./PRECIP-INC/16JAN1973/10MIN/OBS/. This DSS file is part of the Castro example project. Example projects can be installed by selecting the Help ⇒ Install Sample Projects... menu option.

Table 9. Precipitation gage weights.

<table>
<thead>
<tr>
<th>Subbasin</th>
<th>Proctor School</th>
<th>Fire Dept.</th>
<th>Sidney School</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>2</td>
<td>0.20</td>
<td>0.80</td>
<td>0.00</td>
</tr>
<tr>
<td>3</td>
<td>0.33</td>
<td>0.33</td>
<td>0.33</td>
</tr>
<tr>
<td>4</td>
<td>0.00</td>
<td>0.80</td>
<td>0.20</td>
</tr>
</tbody>
</table>
A simulation run for pre-development conditions will be created and computed to determine the existing conditions rainfall-runoff response. Finally, future urbanization will be modeled and results compared to the existing conditions.

Create the Project

Begin by starting HEC-HMS and creating a new project. Select the **File ⇒ New...** menu item. Enter *Castro Valley* for the project “Name” and *Castro Valley Urban Study* for the “Description” (Figure 26). Project files will be stored in a directory called *Castro_Valley*, a subdirectory of the “hmsproj” directory created during program installation. Set the “Default Unit System” to *U.S. Customary* and click the **Create** button to create the project.

![Create a New Project](image)

*Figure 26. Enter the name, description, and default unit system of the new project.*

Set the project options before creating gauges or model components (Figure 27). Select the **Tools ⇒ Program Settings...** menu item. Set “Loss” to *Initial and Constant*, “Transform” to *Snyder Unit Hydrograph*, “Baseflow” to *Recession*, “Routing” to *Muskingum*, “Gain Loss” to *None*, “Precipitation” to *Gage Weights*, “Evapotranspiration” to *None*, and “Snowmelt” to *None*. Click the **OK** button to save and close the *Project Options* window.
Chapter 3 Example

Input Data

Create a precipitation gage for the Fire Department data. Select the Components ⇒ Time-Series Data Manager menu item. Make sure the “Data Type” is set to Precipitation Gages. Click the New... button in the Time-Series Data Manager window. In the Create A New Precipitation Gage window enter Fire Dept for the “Name” and Castro Valley Fire Department for the “Description”. Click the Create button to add the precipitation gage to the project. The Fire Dept precipitation gage is added to the Precipitation Gages folder under the Time-Series Data folder in the Watershed Explorer. Click the plus sign next to the gage name. The Watershed Explorer expands to show all time windows for the precipitation gage. A default time window was added when the gage was created. Select the time window in the Watershed Explorer to open the Component Editor for this precipitation gage. The Component Editor contains four tabs: “Time-Series Gage,” “Time Window,” “Table,” and “Graph.” Select the “Time-Series Gage” tab and select the Data Storage System (HEC-DSS) “Data Source” option. Click the DSS Filename button and locate the CASTRO.DSS file. Click the DSS
Pathname button to view a list of records in the DSS file. Select the /CASTRO VALLEY/FIRE DEPT./PRECIP-INC/16JAN1973/10MIN/OBS/pathname (Figure 28).

To view a time series table and graph of precipitation data, first click on the “Time Window” tab. Enter a “Start Date” and “End Date” of 16Jan1973, a “Start Time” of 03:10, and an “End Time” of 09:50. Click on the “Table” tab to view a table and click the “Graph” tab to view a graph of the Fire Dept precipitation data.

Create a discharge gage for the observed hydrograph at the watershed outlet using the same procedure for creating the precipitation gage. Select the Components ⇒ Time-Series Data Manager menu item. Make sure the “Data Type” is set to Discharge Gages. Click the New... button in the Time-Series Data Manager window. In the Create A New Discharge Gage window enter Outlet for the “Name” and Castro Valley Outlet Gage for the “Description”. Click the Create button to add the discharge gage to the project. Open the Component Editor for the discharge gage and select the Data Storage System (HEC-DSS) “Data Source” option. Navigate to and select the CASTRO.DSS file and choose the record with the /CASTRO VALLEY/OUTLET/FLOW/16JAN1973/10MIN/OBS/ pathname using the appropriate buttons. Using the same steps as described for a precipitation gage, create a time window from 16 January, 1973 at 03:00 hours to 13:00 hours. Click the “Graph” tab to view the observed discharge hydrograph.
Create a paired data table for the modified Puls routing method. Select the Components ⇒ Paired Data Manager menu option. Make sure the “Data Type” option is set to Storage-Discharge Functions and click the New... button in the Paired Data Manager window. Leave the “Name” as Table 1 and enter a “Description” of Reach-2 in the Create A New Storage-Discharge Function window. Click the Create button to add this storage-discharge function to the project. In the Component Editor for this paired data function, make sure the “Data Source” is set to Manual Entry and the “Units” to AC-FT:CFS. Click the “Table” tab and enter the storage-discharge relationship from Table 8 (Figure 29).

![Figure 29. Storage-Discharge table for Reach-2.](image)

**Create the Basin Model**

Begin creating the basin model by selecting the Components ⇒ Basin Model Manager menu item. Create a new basin model with a “Name” of Castro 1 and a “Description” of Existing Conditions.

**Create the Element Network**

The Castro Valley watershed will be represented with four subbasins, two routing reaches, and three junctions. Open the new basin model map by selecting the Castro 1 basin model in the Watershed Explorer. A background map can be added to the basin model by selecting the View ⇒ Background Maps menu item (this menu item is only available if a basin model map is opened in the Desktop). Click the Add... button in the Background Maps window. Navigate to the file called CASTRO.MAP, which is part of the Castro example project (you will need to make sure the file type is set to *.map). Select the file and click the Select button.
This file is added to the “Current background maps” list in the Background Maps window. Click OK.

Use the following steps and Figure 30 to create the element network:

1. Add four subbasin elements. Select the subbasin icon on the tool bar. Place the icons by clicking the left mouse button in the basin map.

2. Add two reach elements. Click first where you want the upstream end of the reach to be located. Click a second time where you want the downstream end of the reach.

3. Add three junction elements.

4. Connect Subbasin-2 downstream to Junction-1. Place the mouse over the subbasin icon and click the right mouse button. Select the Connect Downstream menu item. Place the mouse over the junction icon and click the left mouse button. A connection link shows the elements are connected.

5. Connect the other element icons using the same procedure used to connect Subbasin-2 downstream to Junction-1. Move the hydrologic elements as necessary to complete the network shown in Figure 30. Move an element by placing the mouse over the icon in the basin model map. Press and hold the left mouse button and move the mouse. Release the left mouse button to place the icon. The upper and lower ends of a reach element icon can be moved independently.

The elements will be added to the Watershed Explorer as you create them in the basin model map. The elements will always be shown in hydrologic order, that is, from upstream to downstream ordering. The ordering will be automatically updated as you add elements, change the area for subbasins, or change any downstream flow connections.
Figure 30. Subbasin, reach, and junction elements in their correct positions.

Enter Element Data

Enter the area for each subbasin element. Select a subbasin element in the Watershed Explorer or in the basin model map. Then, in the Component Editor select the “Subbasin” tab and enter the subbasin area (Figure 31). Enter the drainage area for all subbasin elements. Figure 31 also shows the “Loss,” “Transform,” and “Baseflow” tabs. One way of entering parameter data for a subbasin element is to click on each of these tabs and enter the required information. Another way to enter parameter data is to use global editors. Global editors are the most efficient way to enter data for several subbasin and reach elements that use the same methods. Subbasin area can also be entered using a
global editor by selecting the **Parameters ⇒ Subbasin Area** menu item. Select the **Parameters ⇒ Loss ⇒ Initial and Constant** menu item (Figure 32) to open the *Initial Constant Loss* global editor. Enter the loss data from Table 5 (Figure 33) and click the **Apply** button to close the global editor. Select the **Parameters ⇒ Transform ⇒ Snyder Unit Hydrograph** menu item and enter the transform data from Table 5 (Figure 34). Select the **Parameters ⇒ Baseflow ⇒ Recession** menu item and enter baseflow data from Table 6 (Figure 35).

![Subbasin area](image)

**Figure 31.** Subbasin area.
Figure 32. Select initial and constant global editor.

Figure 33. Initial and constant loss global editor.
Change the name of the three junction elements. Click the right mouse button when the mouse is on top of the Junction-1 element name in the Watershed Explorer and select Rename… option in the popup menu. Change the name to East Branch. Change the name of the Junction-2 and Junction-3 elements to Outlet and West Branch, respectively.

Enter parameter data for the reach elements. Open the Component Editor for Reach-1. Change the “Method” from Muskingum to Modified Puls. A screen appears with the message stating that data for the old method will be lost. This message makes it more difficult to accidentally change the method and lose parameter data. Click the
“Route” tab in the Component Editor and select the storage-discharge function from the drop-down list and enter the number of subreaches from Table 7 (Figure 36). Set the “Initial” condition to Inflow = Outflow. Open the Component Editor for Reach-2 and enter the data from Table 7 (Figure 37).

![Figure 36. Modified Puls data for Reach-1.](image)

![Figure 37. Muskingum data for Reach-2.](image)

Add an observed hydrograph to the Outlet element. Select this junction element in the basin model map or in the Watershed Explorer to open the Component Editor. Click the “Options” tab and select the Out gage from the “Observed Flow” drop-down list (Figure 38).

![Figure 38. Add an observed hydrograph.](image)
The basin model is complete.

**Create the Meteorologic Model**

Begin creating the meteorologic model by selecting the **Components ⇒ Meteorologic Model Manager** menu item. Click the **New…** button in the **Meteorologic Model Manager** window. In the **Create A New Meteorologic Model** window enter **Gage Wts** for the “Name” and **Thiessen weights, 10-min data** for the “Description.” Open the **Component Editor** for this meteorologic model by selecting it in the **Watershed Explorer**. In the **Component Editor** make sure the selected “Precipitation” method is **Gage Weights** (Figure 39). At this point the **Watershed Explorer** should look similar to Figure 40.

![Figure 39. Component editor for meteorologic model.](image)

Subbasins need to be specified for this meteorologic model. Click the “Basins” tab in the **Component Editor** for the **Gage Wts** meteorologic model. Set the “Include Subbasins” option to “Yes” for the **Castro 1** basins.
basin model (Figure 41). After this step, all subbasins in the Castro 1 basin model are added to the meteorologic model (Figure 42).

Figure 41. Include subbasins in meteorologic model.

Figure 42. Subbasins added to meteorologic model.

Use the following steps and Figure 42 to complete the Gage Wts meteorologic model:

1. Add the Proctor School and Sidney School non-recording gages to the meteorologic model. Select the Precipitation Gages node in the Watershed Explorer to open the “Total Storm Gages” editor. This node should be located one level under the meteorologic model (Figure 42). Enter Proctor for the “Gage Name” and 1.92 for the “Total Depth”. Add the Sidney total storm gage in the same manner (Figure 43).
2. In the Watershed Explorer, click the plus sign next to the Subbasin-1 element and select the Gage Weights sub-node (Figure 44). A Component Editor will open with two tabs, “Gage Selections” and “Gage Weights.” Depth and time weights are required for all precipitation gages with the “Use Gage” option set to “Yes.” For this example, the Fire Dept gage will be used for all subbasin elements because it contains the storm pattern; the other gages only contain total storm depths. Once the correct precipitation gages are included for Subbasins-1 (Figure 45), select the “Gage Weights” tab and enter the correct “Depth Weight” from Table 9 for Subbasin-1. The “Time Weight” will be 1.0 for the Fire Dept gage in all subbasins (Figure 46). Complete this step for the remaining subbasins.
Define Control Specifications

Create the control specifications by selecting the Components ⇒ Control Specifications Manager menu item. In the Control Specifications Manager window, click the New... button and enter Jan73 for the “Name” and 16 January 1973 for the “Description.” In the Component Editor, enter 16Jan1973 for both the "Start Date" and "End Date" (Figure 47). Enter 03:00 for the "Start Time" and 12:55 for the "End Time." Select a time interval of 5 minutes from the “Time Interval” drop-down list.

Create and Compute a Simulation Run

Create a simulation run by selecting the Compute ⇒ Create Compute ⇒ Simulation Run menu item. Name the simulation run Current. Select the Castro 1 basin model, Gage Wts meteorologic model, and Jan73 control specifications using the wizard. After the wizard closes select the “Compute” tab of the Watershed Explorer. Select the Simulation Runs folder so that the Watershed Explorer expands to show Current. Click on Current to open the Component Editor for this simulation run. Change the description for this simulation run by entering Current conditions for storm of 16 January 1973 (Figure 48).
Click the right mouse button when the mouse pointer is on top of the Current name in the Watershed Explorer and select the Compute option in the popup menu. A window opens showing the progress of the compute. Close this window when the compute finishes.

![Simulation Run](image)

**Figure 48. Component editor for a simulation run.**

**View Model Results**

Begin viewing results by opening the basin model map. Open the Castro 1 basin model map by clicking on its name in the Watershed Explorer, “Components” tab. Select the Global Summary Table tool from the tool bar to view summary results of peak flow for all elements in the basin model (Figure 49). Print the table or make a note of the computed peak discharge for Subbasin-2. View graphical and tabular results for the Subbasin-2 element. Place the mouse over the Subbasin-2 icon in the basin model map and click the right mouse button. Select the View Results [Current] ⇒ Graph menu item (Figure 50). Select the View Results [Current] ⇒ Summary Table menu item to view the subbasin element summary table (Figure 51). Select the View Results [Current] ⇒ Time-Series Table menu item to view the subbasin time-series table (Figure 52).
Figure 49. Viewing the global summary table.
Chapter 3 Example

Figure 50. Graph of Subbasin-2 results.

Figure 51. Summary table of Subbasin-2 results.
Simulate Future Urbanization

Consider how the Castro Valley watershed response would change given the effects of future urbanization. The meteorologic model and control specifications remain the same, but a modified basin model must be created to reflect anticipated changes to the watershed.

Create the Modified Basin Model

The urbanized basin model can be created by modifying a copy of the existing conditions basin model. Place the mouse pointer on the Castro 1 basin model in the Watershed Explorer, “Components” tab, and click the right mouse button. Select the Create Copy… option. Enter Castro 2 as the basin model “Name” and Future conditions for the “Description” in the Copy Basin Model window.
Modify the new basin model to reflect future urbanization. Open the Component Editor for Subbasin-2 (select Subbasin-2 in the Watershed Explorer or in the basin model map). Change the percent imperviousness from 8 to 17 percent and the Snyder \(t_p\) from 0.28 to 0.19 hours.

Update the Gage Wts meteorologic model to include subbasins from the Castro 2 basin model. Select the meteorologic model in the Watershed Explorer to open the Component Editor. Open the “Basins” tab and change the “Include Subbasins” option to “Yes” for the Castro 2 basin model.

**Urbanized Simulation Run**

Create a new simulation run for the future conditions basin model by selecting the **Compute** ⇒ **Create Simulation Run** menu item. Name the simulation Future and select the Castro 2 basin model, the Gage Wts meteorologic model, and the Jan73 control specifications using the wizard. Open the Component Editor for Future and enter Future conditions for storm of 16 January 1973 as the description. Compute the simulation and compare the peak discharges for the urbanized conditions basin model to the existing conditions basin model at elements Subbasin-2, East Branch, and Outlet (Table 10).

<table>
<thead>
<tr>
<th>Subbasin</th>
<th>East Branch</th>
<th>Outlet</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing</td>
<td>171</td>
<td>304</td>
</tr>
<tr>
<td>Urbanization</td>
<td>211</td>
<td>337</td>
</tr>
<tr>
<td>Increase</td>
<td>23</td>
<td>11</td>
</tr>
</tbody>
</table>

Results from the two simulation runs can also be compared from the “Results” tab of the Watershed Explorer. Results are available from the “Results” tab as long as no modifications have been made to components used by the simulation run. For example, if a constant loss rate parameter was changed in a subbasin element, then results for that subbasin element and all downstream elements will not be available. It is easy to determine if results are available. If the simulation run icon is grey, then results are not available (Figure 53) and the simulation run must be re-computed.
Figure 53. Results are not available for simulation runs until they are recomputed.

Use the Watershed Explorer to compare results from both simulations. Click the “Results” tab in the Watershed Explorer and select both simulation runs. The Watershed Explorer expands to show all hydrologic elements with results. Then, select Subbasin-2 and watch the Watershed Explorer expand to show all results available for this subbasin element (Figure 54). Select the Outflow result from the existing conditions simulation and notice the preview graph in the Component Editor. Hold down the Control key and select the Outflow result from Subbasin-2 in the future conditions simulation. The hydrograph from the future condition simulation is added to the preview graph (Figure 55). Select the View Graph tool bar button to open a copy of the preview graph.

Figure 54. Available results for Subbasin-2.
Figure 55. Comparing hydrographs from existing and future conditions simulations.

Save the project by selecting the File ⇒ Save menu item. The example application is now complete.
Appendix

Create and Compute an Optimization Trial

Model optimization involves adjusting parameter values so that the simulated results match the observed stream flow as closely as possible. Two different search algorithms are provided that move from the initial parameter value to the final best value. A variety of objective functions are provided to measure the goodness of fit between the simulated and observed stream flow in different ways. While model optimization does not produce perfect results, it can be a valuable aid.

An optimization trial is created by selecting the Compute ⇒ Create Compute ⇒ Optimization Trial menu option. A wizard steps the user through the process of creating an optimization trial. First, a name must be entered, then an existing basin model must be selected, a hydrologic element containing observed flow must be selected, and finally a meteorologic model. The new optimization trial is added to the “Compute” tab of the Watershed Explorer (Figure A1). Notice the trial is added under the Optimization Trials folder. Select the optimization trial to open the Component Editor (Figure A1). In the Component Editor, the user can enter a “Description”, change the basin or meteorologic models used by the optimization trial, enter start and end dates for the trial, and select the search method used to find optimal parameter values. Also, the user has the option of changing the tolerance and the number of iterations to control when the search for optimal parameter values ends.

Click the plus sign next to the optimization trial name to expand the Watershed Explorer. Select the Objective Function node in the Watershed Explorer to add a new tab to the Component Editor (Figure A2). On this editor the user can select the objective function from the “Method” drop-down list and change the location used for comparing observed and simulated hydrographs. In addition, start and end dates and times can be edited. This time window is used when the program computes the objective function; only data within the time window is used.

An optimization trial requires hydrologic element parameters. To add a parameter, click the right mouse button when the mouse is on top of the optimization trial’s name in the Watershed Explorer and select Add Parameter (Figure A3). A new sub-node is added to the Watershed Explorer with the name Parameter 1. Figure A4 shows the editor for this new sub-node. In this editor the user selects the hydrologic element and a parameter for that element. This parameter is adjusted automatically during the optimization trial in an attempt to find a value which minimizes the difference between simulated and observed hydrographs. The user has the option to select a different initial value for the parameter, enter
minimum and maximum value constraints, and select whether the parameter is locked during the optimization trial. More than one parameter can be added to an optimization trial.

An optimization trial can be computed from the Compute menu, Compute toolbar, or from the Watershed Explorer. Results for an optimization trial are available from the “Results” tab of the Watershed Explorer and from the basin model map. Click the plus sign next to the Optimization Trials folder to expand the Watershed Explorer, “Results” tab. Select the optimization trial and the Watershed Explorer will expand to show all results available for the trial.

Figure A1. Optimization trial.
Figure A2. Objective function editor.

Figure A3. Add a parameter to an optimization trial.

Figure A4. Parameter tab (The editor updates when changing the “Element” and “Parameter” options).
Create and Compute a Depth-Area Analysis

The depth-area analysis automates the process of producing flow estimates due to frequency precipitation at multiple points of interest within a watershed. The frequency precipitation is automatically adjusted to reflect the drainage area at each point of interest.

Before a depth-area analysis can be created, a simulation run using a frequency storm meteorologic model must exist. A depth-area analysis is created by selecting the \textbf{Compute} $\Rightarrow$ \textbf{Create Compute} $\Rightarrow$ \textbf{Depth-Area Analysis} menu option. A wizard steps the user through the process of creating a depth-area analysis. The user must enter a name for the depth-area analysis and then select an existing simulation run (only simulation runs using the frequency storm method will be shown in this list). The analysis will use the basin model, meteorologic model, and control specifications from the chosen simulation run. The new depth-area analysis is added to the “Compute” tab of the \textit{Watershed Explorer} (Figure A5). A new analysis can also be added to a project using the \textit{Analysis Manager}. Click on the analysis to open the \textit{Component Editor}. In the \textit{Component Editor}, the user can enter a “Description” and change the simulation run used by the depth-area analysis.

A depth-area analysis requires the user to select points, hydrologic elements, in the basin model where outflow from a frequency event is needed. The depth-area analysis automatically adjusts precipitation depths in the selected frequency storm meteorologic model to reflect the upstream drainage area for each analysis point. A separate simulation is computed for each analysis point using the correct depth-area adjustment. The user selects points of interest (analysis points) on the “Analysis Points” tab (Figure A6). Click the mouse in the first row of the “Element” column and a drop-down list will appear containing hydrologic elements in the basin model.

A depth-area analysis can either be computed from the \textbf{Compute} menu, the \textbf{Compute} toolbar, or from the \textit{Watershed Explorer}. Results for a depth-area analysis are available from the “Results” tab of the \textit{Watershed Explorer}. Additionally, results are only available for hydrologic elements selected as analysis points.
Figure A5. Component editor for a depth-area analysis.

Figure A6. Selecting analysis points for a depth-area analysis.