Upper Brushy Creek GeoRAS model development
[bookmark: _GoBack]By Dean Djokic, Environmental Systems Research Institute, Redlands, CA., March 2012
Defining input data for GeoRAS model development
Input data are a mix of existing data and some creative attribution.  The starting point is terrain dataset derived from Lidar.  Modeling area is around Walsh Drive where damage to the property occurred during Hermine event.  A stretch of about 500 m upstream from the confluence of Brushy Creek and South Brushy Creek (along both of them) and 400 m downstream from that confluence is modeled.
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The existing terrain dataset is exported into a 0.5m DEM.  DEM is used instead of TIN since it is needed later on for depth calculations.
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Executing: TerrainToRaster newterrain_brushy C:\Public\Erika\Hydraulics\Layers\UBCAOI FLOAT LINEAR "CELLSIZE 0.5" 0
Start Time: Mon Mar 05 22:32:50 2012
Succeeded at Mon Mar 05 22:33:06 2012 (Elapsed Time: 16.00 seconds)

Using GeoRAS tools, the following layers were created:
· River.  It is populated using the stream geometry obtained from Lidar terrain.
· Flowpaths.  Centerline is obtained from river geometry.  Left and right flowpath were generated as parallel lines to the centerline (with slight manual modifications).
· Banks.  Banks were generated as parallel lines to the centerline (with slight manual modifications).
· XSCutLines.  They were generated using the “Construct XS Cut Lines” GeoRAS tool (600 ft wide and 80 ft apart) and then manually cleaned.
· LandUse.  A single polygon was digitized with Manning’s n of 0.045.

The final model layout looks like:
[image: ]

HEC-GeoRAS Preprocessing
This section covers most of the exercise 9.I in the H&H class materials.  
1. Open new ArcMap project. Make sure “HEC-RAS” toolbar is visible.
2. Load the following data from project folder:
a. ..\Layers\UBCAOI DEM.
3. Load the following data from the project geodatabase ..upperbrushyras.mdb (Layers feature dataset):
a. Banks, Flowpaths, LandUse, River, and XSCutLines.
4. Save ArcMap project in the exercise directory.
5. Run “RAS Geometry -> Layer Setup” function and define loaded layers.
6. Inspect each of the added layers.  Zoom in to see details of terrain and other layers.  Notice how “sparse” with the attributes the layers are.  The following are required attributes for each layer (they all have HydroID):
a. Banks – nothing
b. Flowpaths – LineType
c. Land use – N_value
d. River – River and Reach
e. Cross-section cut lines – nothing
7. Check out the NodeName attribute in the cut line feature class.  It is populated for only few cross-sections.  These cross-sections are the flow exchange locations where discharges computed in GeoHMS will be applied to the computations in RAS.  These are usually the junctions in the HMS model (that is why they are all prefixed by “J”).  The value in that field is the name of the GeoHMS element whose discharge will be used for flow definitions in the stead and unsteady flows.  Few other cross-sections also have node name populated – these are other “important” nodes that might be used to define boundary conditions.
8. Run the following functions from the “RAS Geometry -> Stream Centerline Attributes” menu:
a. Topology 
b. Length/Stations 
c. (do not run Elevations function)
d. Check the structure of River feature class.
9. Run from the RAS Geometry menu all the functions in the “XS Cut Line Attributes” menu including the Elevations function.  After each function, check the structure of the cross-section feature class.  (Close the table between running the functions as having the table open slows somewhat the execution of the function).
a. (or, if you are lazy, just run the “All” function to execute all the functions in that menu)
10. Run from the RAS Geometry menu the “Manning’s N Values” -> Create LU- Manning Table function.  Accept defaults in the form.  Check the structure of the LUManning table.  The N_Value field is empty.  It is up to the user to enter the appropriate N values for each of the land use categories.  NOTE.  This function is useful if you have a land use layer for which you do not have the n values defined.  The created table helps in defining which land use types are in the land use layer and provides the place to enter associated n values.  If the land use layer already has a field with n values, this function/operation is not needed.
a. Calculate the N_Value to 0.045.
11. Run from the RAS Geometry menu the “Manning’s N Values -> Extract N Values” function.  For “Select Manning Option” select “Table of Manning Values” and specify “LUCode” from the from the pull down list for “Landuse Field”.  Check the structure of the resulting Manning table.  Notice the use of XS2DID field (HydroID of the cross-section) as the link between the cross-section and the table.
12. (Do not run this part if you run 10 and 11).  Run from the RAS Geometry menu the “Manning’s N Values -> Extract N Values” function.  For “Select Manning Option” select “Manning Values in Landuse Layer” and specify N_value from the pull down list (unless you modified the LUManning table defined in the previous step).  Check the structure of the resulting Manning table.  Notice the use of XS2DID field (HydroID of the cross-section) as the link between the cross-section and the table.
13. Run from the RAS Geometry menu the “Export RAS Data” function.  Note the name and directory of the output file(s) that will be generated (you can specify location and name of the output file).  Inspect using notepad each of the three generated files (*.sdf, *.xml, and GIS2RASTmpFile.xml).



Assembling and Running RAS Project
This section covers most of the exercise 10 in the H&H class materials.  

Importing GeoRAS geometry
1) Start HEC-RAS 4.1 and create a new project (“File -> New Project …”).
2) Specify the project name (e.g. Upper Brushy Creek AOI) and the file name (e.g. UBCAOI.prj).  It is useful to store all the RAS projects in the same directory if you are going to make many models.
3) Start geometric editor (“Edit -> Geometric Data …”).
a) From the geometric data window, import GIS data (“File -> Import Geometry Data – GIS Format …”).  
i) In the input form, navigate to the .sdf file created with GeoRAS in previous exercise (e.g. GIS2RAS.RASImport.sdf), select that file, and click OK.
b) Review the Import Options form.  It has several tabs that allow you to select what data are to be imported into RAS.  (These options can be very useful when importing only a portion of the data into an existing project.)  Click on “Finished – Import Data” button to import all the data as they are.
c) Review the imported geometry.  Compare it with data in GeoRAS.  Save the geometry dataset (“File -> Save Geometry Data) – make sure you provide the title for the geometric dataset (can be anything).
d) Cross-section profile lines generated through GIS will have a lot of vertices that are often not representing significant changes in cross-section and also sometimes generate too many (over 500) points per cross-section (especially if the terrain is derived from Lidar data).  RAS provides a tool to filter out the unnecessary points.  From Tools menu, run “Cross Section Points Filter …”.
i) Select “Multiple Location” tab.  
ii) Select “All Rivers” for “River” pulldown.
iii) Select all cross-sections to be filtered (by clicking on the right-arrow button in the middle of the form).  
iv) Review the number of vertices per cross-section (number in brackets next to the cross-section name).  you will notice that most of the cross-sections have over 1,000 vertices.
v) Use default filter tolerances.  
vi) Click on “Filter Points on selected XS” (note – clicking on OK before clicking on the filter points on selected XS will NOT do the filtering).  
(1) You will be presented with a list showing the filtering results.  If satisfied, click on “close” and then on “OK” on the “Cross Section Point Filter” form to accept the changes.  Make sure you click on OK, if you just close the filter form without clicking on OK the changes will not be made.
(2) If you want further simplification, click on “close”, then modify filtering tolerances and rerun the filter.  You will have to do this at least twice due to the large number of points in cross-sections.  If you are having hard time getting the right parameters, set “Colinear Minimum Change in Slope” to 0.05.
e) Save the geometry and close the geometry data editor.




Defining the steady flow data
This example shows flows from a 100-year design event.  Since there are two branches, two flow conditions will have to be defined on the upstream cross-sections of the two branches, and one downstream boundary condition.  Since Walsh Dr. is a low crossing, it is anticipated that critical depth will develop during major storms (when the road overtops), so that will be selected as the downstream boundary condition (to be associated with “WalshU” cross-section).
The flows for the two branches are assumed to be constant (due to short length of modeling reaches) and are obtained by looking at HMS results for junction “J337” (confluence of the two main branches of Brushy Creek).
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The overall peak flow at the junction occurred at 13:45 (although this does not match peak flow timings for all the inflow components into the junction).  The flows from element W1300 and R520 (South Brushy Cr.) are combined and will be design flow for southern branch and flows for elements W1290 and R550 are combined for the northern branch (main branch).  The values are:
· Qs =  106 + 22,992 =~ 23,200 cfs (to be associated with “SouthBranchFBC” cross-section).
· Qn = 676 + 47,734 =~ 48,400 cfs (to be associated with “NorthBranchFBC” cross-section).
These flows are unrealistic and have to be adjusted for impact of the dams in the system.  As an initial estimate, 1/3 of the HMS model results were used as the input into the RAS model.
Alternative flows – Hermine with dams
Flows for Hermine event based on HMS model with the 8 reservoirs produces dramatically lower flows.  These flows are used for the analysis .
· Qs = 2,500 cfs.
· Qn = 16,300 cfs.
For the downstream boundary condition, normal depth (slope = 0.008) is used since Walsh Dr. road is not in the DEM and it does not show as a “weir” but rather a regular cross-section.  (It would be possible to add a structure in RAS at that location and rerun the analysis and see the difference). 
1. Start steady flow data editor (“Edit -> Steady Flow Data …”).
2. The default flow boundary conditions for subcritical flow will be displayed (most upstream cross-section in each reach).  For each, enter the appropriate flows:
i. River = Brushy, Reach=Upper, RS=2840, PF 1=16,300.
ii. River = Brushy, Reach=Lower, RS=945.4837, PF 1=18,800.
iii. River = South Brushy, Reach= Lower, RS=1440, PF 1=2,500.
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3. Click on the “Reach Boundary Conditions” button.  Once the “Steady Flow Boundary Conditions” form opens you will notice that there are three locations boundary conditions.  Since we are modeling subcritical flow, we need to define the downstream boundary condition.  For the two upper reaches, they are the condition at the confluence.  For the most downstream reach, you have to specify what it is.  We will set it to the normal depth (other alternatives can be explored).
i. Click on the empty “Downstream” form and click on “Normal Depth” button.
ii. Enter 0.08 as the downstream slope for normal depth and click OK twice to set up the boundary conditions.
[image: ]
4. Save flow data (“File -> Save Flow Data”), provide name for it, and close the “Steady Flow Data” form.

Defining and running RAS steady-state analysis
1. Start steady flow analysis editor (“Run -> Steady Flow Analysis …”).
i. Define a new plan (“File -> New Plan”).
1. Specify the title for the plan
2. Specify the short plan identifier (do not start with a number or a “funny” character, and do not have spaces).
ii. If you want to map velocities, click on “Options” and select “Flow Distribution Locations …”.
1. Specify value of 15 sub-sections for LOB, Channel, and ROB in the “Set Global SubSections” portion of the form (there can be at most 45 sub-sections total).
2. Click on OK to accept the changes.
[image: ]
iii. Click on the “Compute” button to execute the run.
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iv. If there are any, review the error list generated by RAS and fix any problems.  Save any changes you make.  Rerun the analysis and do any additional fixes if need be.
v. During the run, any warnings will be presented in the computation message portion of the form.  Review any of the entries there and see if any changes need to be made to the model.  
vi. Click on “Close” button to exit the hydraulic computation form.
vii. Close the “Steady Flow Analysis” form.
viii. Save the RAS project.
2. Review RAS results using any/all RAS result viewing tools.  
3. Make any changes to the model if necessary and rerun the analysis.  Repeat the process until final results are obtained.  Evaluate RAS and HMS results for consistency.  Update the models if necessary.
4. Save the RAS project.
5. Open the GIS Export form (“File -> Export GIS Data…”).
i. Specify the location and name of the export (*.RASexport.sdf) file.
ii. Select the profile(s) to export (make sure you click on the desired profile).
iii. Pick which geometry data export options you want (select all of them).  The final form should look like the following figure. 
[image: ]
iv. If you have selected to map velocities, check “Export Velocity Distribution” and “Bank Stations” options.
v. Click on “Export Data”.
6. Save and close HEC-RAS.
7. Review the RAS export sdf file.  
i. Can you tell the difference from the import .sdf file format?

GeoRAS Post-processing
This section covers most of the exercise 11 in the H&H class materials.  

Importing RAS results
1. Open an existing ArcMap GeoRAS project or start a new ArcMap project.  Make sure GeoRAS toolbar is active.  If you have started a new project, save it.
2. Click on “Import RAS SDF File” button ([image: ]) from GeoRAS toolbar (this step converts the sdf file into an XML formatted file – it does not actually import the data).
i. Select the sdf file created in exercise 10 (this is of “RASExport” type).  Note the name of the output file (same as the input file but with xml extension).
ii. Click on OK to perform the format conversion.
3. Define the new import project by running Layer Setup (from “RAS Mapping” menu on the GeoRAS toolbar).  Define:
i. Name of the new analysis (any name)
ii. Name of the RAS GIS export file (created in step 2)
iii. Which terrain dataset to use (same grid used in exercise 9 - ubcaoi).
iv. Output directory
v. Rasterization cell (accept default)
vi. The completed form should look like the following figure.
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vii. Click on OK.  A new data frame will be created with the name matching the name of the analysis, with the specified terrain dataset loaded in it.  The actual import of the data has not been performed yet.  (The terrain is turned off by default, so the new data frame will appear empty).
4. Save the project.
5. Import GIS data (“RAS Mapping -> Import RAS Data”).  The process might take few minutes depending on the complexity of the results.  During the process, several informative messages will be displayed in the form.
6. Depending on the data that were exported from RAS, two or more feature classes will be created.  At least the XS Cut Lines and Bounding Polygon feature classes as well as the Profile Definition tables will be created.  Additional feature classes will be created if exported from RAS.
i. Explore the created dataset.  
1. Review XS Cut Lines feature class and identify the attributes with water surface elevations calculated by RAS.  
a. Check if there are any interpolated cross-sections.  If there are, carefully review their location and if necessary, add those cross-sections in the pre-processing and redo the export (basically replacing the interpolated cross-sections with ones extracted from terrain.
2. Review the bounding polygon feature class.
3. Review other feature classes if available.

Defining floodplain
1. Create water surface TIN (water surface bound only by the extent of the bounding polygon) by running Water Surface Generation function (from “RAS Mapping -> Inundation Mapping” menu).  
a. Select one or several profiles for which to create the water surface TIN.  In our case there will be just one profile.
b. Check “Draw Output Layers” if you want to display the TIN (you might not want to do that if you select many profiles to generate at one time).
c. Select other options for smoothing and merging floodplain polygons (normally, keep these options unchecked).
2. Generate floodplain and water depth (by running “RAS Mapping -> Inundation Mapping -> Floodplain Delineation Using Rasters” function).  
a. Select one or several profiles for which to create the floodplain extent (depth grid will be created automatically).  Only those profiles processed in step one will be available for processing.  
b. Check “Draw Output Layers” if you want to display the output layers.
c. Check “Smooth Floodplain Delineation” if you want to smooth the output floodplain polygon (but you should not do that in the initially).
d. For each selected profile, a depth grid and a floodplain polygon feature class will be created.
3. Review the results.  Relate the floodplain shape and behavior to the assumptions of 1-D flow in RAS.  Pay special attention to the following:
a. Where floodplain polygon extends all the way to the bounding polygon. This might indicate locations where cross-sections were not defined wide enough.
b. Where there is a break in floodplain polygon.  This might indicate that cross-sections were not placed close enough.
c. Where there are isolated flooded areas (either on the cross-section or not).  This might indicate isolated areas that should not be included as the flow contributing areas.
d. Where there are “flares” in the floodplain.
e. Where flow path lines (used to determine distances between cross-sections) are not within the floodplain.
f. If water surface extent points are not on the floodplain boundary.
g. Other unusual floodplain features.
4. If necessary modify RAS or GeoRAS models and redo the analysis until satisfactory results are obtained.
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Velocity mapping
1. Create velocity distribution within the flooded area by running Velocity Mapping function (from “RAS Mapping” menu).  
a. Select one or several profiles for which to create the velocity distribution.
b. Check “Draw Output Layers” if you want to display the grid (you might not want to do that if you select many profiles to generate at one time).
c. For each selected profile, a velocity grid will be created.
2. Review the results.
a. Identify areas where both velocity and depths are high.
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