Converting a LAS Data to a DEM and Performing a Watershed Delineation

Prepared by Cassandra Fagan and David R. Maidment

Contents
Converting a LAS Data to a DEM and Performing a Watershed Delineation.................................................. 1
Purpose .............................................................................................................................................................. 1
Determining LAS files for Study Area ........................................................................................................... 1
Converting LAS files to a DEM....................................................................................................................... 8
Hydrologic Processing .................................................................................................................................... 14
1) Fill............................................................................................................................................................ 15
2) Flow Direction ........................................................................................................................................... 16
3) Flow Accumulation .................................................................................................................................... 17
4) Stream Definition ....................................................................................................................................... 19
5) Watershed Delineation ............................................................................................................................... 21
Using LAS files for other areas in Travis County .......................................................................................... 26

Purpose
The purpose of this tutorial is to provide a workflow for converting LIDAR (Light Detection and Ranging) LAS data to a Bare Earth digital elevation model (DEM) and perform a watershed delineation using the Hydrology tools in ArcGIS.

Determining LAS files for Study Area
Open ArcMap and select the empty map option. If you are using Windows 7, hit the Start button and you’ll see a series of options for ArcGIS. Select ArcMap.
If you are using Windows 8, you’ll see ArcMap 2 in your Windows display. If you don’t see that, then just type “ArcMap.” and you’ll see the program symbol appear. Use the Add Data button to add the data for this exercise to the ArcMap display.

In ArcMap select Customize ➔ Extensions ➔ Spatial Analyst extension.

We will be using this during the tutorial.

Select add Base Map
Select Topographic and add.
Zoom to the approximate area you are looking to work with. For this example the University of Texas Intramural Fields located on Guadeloupe and 51st street will be used.

Once you have located the area you would like to work with, it is time to determine the LAS files you will need for the analysis. For this tutorial the data may be found in the Tutorial zip file on the course website, http://www.ce.utexas.edu/prof/maidment/CE365KSpr15/Terrain/TerrainData.zip, or on the
Austin disk server: `\austin\disk\engr\research\digital-campus\CAPCOG-2012\tutorial`. Extract the files from the zipfile to a folder titled “Tutorial”.

**Connect to these folders by** selecting connect to folder and pasting the folder location or navigating to the folder you wish to connect to.

In the Tutorial folder, navigate to `ortho_sheet_windows → Austin.shp` and add Austin.shp to your map clicking and dragging it into the map display window.

Grids will show up on the screen covering the topographic map. Turn off the fill color by selecting the color block below Austin in the Layers window.

**Change** the fill color to **no color** and select **OK**.
To determine the LAS files you will need, use the select by rectangle tool, and draw a box around your study area. The selected polygons contain the names of the LAS files that cover the study area.

Right-click the austin layer → select attribute table → select show selected records at the bottom.
AUSTIN_EAST-NWC4 & AUSTIN_EAST-SWA2 are the LAS files that you will need to create a DEM of the intramural field study area. These are provided in the zip file.

Before doing any processing it is a good idea to first create a Geodatabase in the folder you will be working with. Some tools will not work properly if the outputs are not stored in a geodatabase.

From ArcMap, open ArcCatalog, navigate through Folder Connections to a place where you want to have a workspace, and create a new File Geodatabase.
Call this IntramuralFields.gdb. Within the geodatabase create a Feature Dataset and call this BaseData.

Choose a Geographic Coordinate System ➔ NAD 1983 (2011) StatePlane Texas Central FIPS 4203 (US feet) and select Next, Next and again to bypass having a Vertical Coordinate system, and Finish to complete creating the Feature Dataset, leaving the tolerance information at the default values.
It is often helpful to set **Map Document Properties** to store relative pathnames to data sources. Then if you keep the map document and its data in the same folder and move the entire folder between computers the references to the data in the map will persist.

To do this go to File → Map Document Properties → **Store relative pathnames to data sources**

Also, if you open your ArcMap Ex1.mxd file later from another location in your file system, you may see a red exclamation points beside your feature classes. If this happens, in ArcMap, right click on the feature class use **Data/RepairData Sources** to relocate the file location where the corresponding data are now stored and your map will display correctly again.

**Converting LAS files to a DEM**
The main steps to converting the LAS files to a DEM include creating the LAS dataset and converting the LAS dataset into a raster.
To convert the LAS files to a LAS dataset navigate to ArcToolbox → Data Management Tools → LAS Dataset and double click **Create LAS Dataset**.

Or alternatively, in the search window search **Create LAS Dataset**, and select the first option.

In the input files, browse for folders and select the **LAS files** folder found in the zip file.

Select the folder you are using to store you project as the Output LAS Dataset folder. Do not enter any surface constraints, or input features.
Important: Select NAD_1983_2011_StatePlane_Texas_Central_FIPS_4203_Ft_US as the Coordinate System, and select OK. If you forget this step, your LAS Dataset will not cover your study area. It should only take a minute or two to create the LAS Dataset.

The output LAS data set will appear in your table of contents window, pictured below. If you unselect the austin layer, you should notice that the LAS dataset covers the same extent of your study region.
Right-click on the LAS dataset in the table of contents window and select **Properties**. Select the filters tab, and under Classification Codes select **2 Ground**, make sure it is the only code selected and click OK. **This is a very important step.** If other codes are selected, the DEM will include points other than the Bare Earth and will take a lot longer to process.
Point cloud data obtained from LiDAR surveys represent elevations of various landscape features. These features are classified into codes, seen in the filter tab. Various digital elevation models can be produced from this data. Since we are going to be performing a hydrologic analysis on this DEM, the ground classification code will be the only code used to create what is known as a Bare Earth DEM. For more information on LiDAR Data visit: https://lta.cr.usgs.gov/LIDAR

To convert the LAS Dataset to a Bare Earth DEM, select Toolbox → Conversion Tools → LAS Dataset to Raster.

Select the LAS Dataset you just created as the Input LAS Dataset. Select the file Geodatabase you created earlier as the location for the Output Raster. In the Value Field, leave the default as ELEVATION.

Change the Interpolation method to Triangulation, select Natural Neighbor as the Interpolation Method, and leave the default Point Thinning Type to No Thinning. Select the sample size, or cell size you would like for your DEM and select OK. The units will be in feet, because those are the units of the Geographic Coordinate System. I recommend a 5-15 ft DEM sampling value depending on the size of your study area. The smaller the sampling size, the longer it will take to process the DEM. It took approximately 20 minutes to produce the 10 ft DEM for this area.
**Hydrologic Processing**

Watershed and stream network delineation can be done using the Bare Earth DEM and the Hydrology tools in ArcGIS. The Hydrology tools are used to derive several data sets that collectively describe the drainage patterns of the basin. Geoprocessing analysis is performed to fill sinks and generate data on flow direction, flow accumulation, streams, stream segments, and watersheds.

A model builder has been created to assist you in this process. You can load this toolbox into your ArcToolbox by right-clicking ArcToolbox → Add Toolbox...

The toolbox is located in the toolbox folder in the zip file.

Select Tutorial.tbx and click OK. The tutorial toolbox will appear in the ArcToolbox menu. Expand the toolbox, right-click Model and select Edit.
This window will appear on the map screen.

These are each of the Geoprocessing tools that need to run.

1) Fill
This function fills the sinks in a grid. If cells with higher elevation surround a cell, the water is trapped in that cell and cannot flow. The Fill function modifies the elevation value to eliminate these problems.

Double click on the fill box in the tutorial window. The tool input and output window will appear. Select the Bare Earth DEM as the Input surface layer, select the Intramural Fields Geodatabase as the location for the Output Surface Raster, name the file IF_DEMFill and select OK. The input and output window is pictured below.
Double click on Flow Direction to open the tool’s input and output window. The filled DEM will be the input raster for the next tool, Flow Direction.

2) **Flow Direction**

This function computes the flow direction for a given grid. The values in the cells of the flow direction grid indicate the direction of the steepest descent from that cell.

Double click on the Flow Direction box in the model builder window. Select IF_DEMFILL as the input surface raster, and locate the geodatabase you are working in to save the flow direction raster. Name the Output Flow Direction Raster IF_FlowDir, the optional output drop raster IF_FlowDirDrop, and select OK.
3) Flow Accumulation
This function computes the flow accumulation grid that contains the accumulated number of cells upstream of a cell, for each cell in the input grid.

Double-click the flow accumulation box, and enter the IF_FlowDir raster as the Input Surface Raster and fill in the rest of the information seen below. Press OK.
Now the model is ready to run.

Select Model → Run in the menu bar
Navigate to the Geodatabase you are using. Notice that there are three new rasters that were created from the model builder toolbox. Add the Flow Accumulation raster to your map window.

4) Stream Definition
Let's define streams based on a flow accumulation threshold within this watershed. Select Spatial Analyst Tools → Map Algebra → Raster Calculator and enter the following expression, using the name \texttt{Str} for the output raster.
The result is a raster representing the streams delineated over the DEM. To change the coloring right-click on the color block below Str in the table of contents window. It looks nice to change the 0 values, indicating there is no stream, to no color and changing the 1 values, indicating there is a stream to a blue color.
5) Watershed Delineation

En lieu of having no defined outlet point for the Intramural Field, the method I used was to zoom into the area of interest, hover over the stream network outside of the field and copy the coordinates into an excel table seen below. Save this table in the same folder you are working in. The Excel file is found in the Outlet Excel File folder of the zip file.

Select add data , navigate to the saved excel worksheet, and double-click. Select Sheet 1.
Select add. Your worksheet will appear in the table of contents, right-click on the worksheet and select **Display X-Y Data**.
Select OK. As seen below, a point appeared on the stream segment.
Export this point to a feature class in your Geodatabase by right-clicking Sheet1$Events (the XY events layer from the gage site spreadsheet) and select Data / Export Data. Name this point Outlet.

Select Spatial Analyst Tools → Hydrology → Watershed

Select IF_FlowDir as the Input Flow Direction Raster, and Outlet as the feature pour point.

Select OK, and the tool will generate the watershed draining to the outlet point selected.
Using LAS files for other areas in Travis County

These are the same steps as followed in the tutorial to convert the LAS files to a DEM, but because of the large file size the dataset it is only accessible through the Austin disk server.

The main steps to converting the LAS files to a DEM include creating the LAS dataset and converting the LAS dataset into a raster.

To convert the LAS files to a LAS dataset navigate to ArcToolbox → Data Management Tools → LAS Dataset and double click **Create LAS Dataset**.

Or alternatively, in the search window search **Create LAS Dataset**, and select the first option.
In the input files, navigate to the LAS files needed for your study area. The entire LAS dataset is found in the following location: `\austin.utexas.edu\disk\eng\research\digital-campus\CAPCOG-2012\Classified_LAS`. Connect to this folder before attempting to extract the LAS files.

Select the files that you need for your study area, and enter a location for your output files. Choose the Output folder being used to store your data. Do not enter any surface constraints, or input features.

**Important:** Select `NAD_1983_2011_StatePlane_Texas_Central_FIPS_4203_Ft_US` as the **Coordinate System**, and select OK. **If you forget this step, your LAS Dataset will not cover your study area.** It should only take a minute or two to create the LAS Dataset.