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Introduction 
3D modeling is becoming an integral part of the world. The use of 3D maps allows users to 

better communicate ideas and information about what is being analyzed by creating a 3D perspective of 

the environment of interest.   ArcGlobe is an ArcGIS application that allows you to transform 2D data 

into 3D visualization models. Realistic models created in ArcGlobe can be used in planning and decision 

making scenarios, one example being rainwater harvesting.  

 Water availability is being affected by recent droughts and growing populations. Recent 

applications such as rainwater harvesting are becoming popular alternatives to help meet demand. 

As an area of study, Honolulu has very intense rainfall which makes it suitable for the collection of 

rainwater. This paper will focus on developing a 3D house model and using the model to determine 

the rainwater capture capacity within the city of Honolulu.  

Objective 
The objective of this paper will be to develop a 3D model which will be used to determine 

the overall capacity of rainwater capture. An initial 3D model of residential buildings in Honolulu 

has been obtained from CyberCity3D. CyberCity3D is a 3D modeling company specializing in GIS 

products such as high resolution 3D buildings, solar roof measurements, and 3D building 

measurements information. The data provided includes all roof details that will aid in the analysis. 

Method 
Data for the house model has been obtained from CyberCity3D. The first step taken was to study the 

files obtained and identify a house for the model. As seen in Figure 1, the file obtained covers a wide 

number of residential homes, a total of 2510 records. This company focuses on mapping high resolution 

3D buildings which can be used in applications such as solar roof measurements. This project focused in 

their detailed basic roof information to recreate a feature class that can be regenerated by interested 

individuals.  

The house geometry used is defined by EGID hwa00006917. Figure 2 shows the gable style roof model 

selected along with its measurements.  The following steps cover the creation of the 3D model.  
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Figure 1: Honolulu Basic Roof Data Provided by CyberCity3D 

 

 

Figure 2: House model selected for study 

The following are the steps needed to generate a 3D model. 

 Research building measurements (obtained from CyberCity3D as indicated above). 

 Create a 2D polygon feature class in ArcMap. 

 Convert 2D polygon shapefile into a multipatch shape file. 

 Use SketchUp to redefine building shape. 

 Importing the SketchUp model created into ArcGlobe. 

House modeled 
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Generating 3D Building 
Building Measurements (obtained from CyberCity3D as indicated above) 

ArcScene was utilized to obtain specific length and height measurements since the measurements 

provided in the file obtained from CyberCity3D was based on total area. Detailed lengths are shown in 

Figure 3. 

 

Figure 3: Measurements obtained using ArcScene 

Creating a 2D polygon Feature Class in ArcMap 

A geodatabase was first created in order to store the feature class. Open ArcCatalog, find the folder 

where you want to save the geodatabase. Right click on the folder, click New>File Geodatabase>Type in 

Name . Create a Feature Dabaset to store the feature class in. Right click on the Geodatabase that was 

created>click New>Click New Feature Dataset> Type in Name and click Next. Choose the coordinate 

systems that is to be used for latitude and longitude coordinates. This project uses 

NAD_1983_StatePlane_Hawaii_3_FIPS_5103_Feet since the home is located in Honolulu, as shown in 

Figure 6. Click on Next>Next>Finish. 
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Figure 4: Generating a new File Geodatabase 
Figure 5: New Feature Dataset 
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Right-click on the New Feature Dataset created and click New>Feature Class. Name the New Feature 

Class>Identify the type of features stored in this feature class as a Polygon Features>Click Next>Leave 

database storage configurations as Default>Click Next>Leave fields as is and click Finish.  

The following steps were taken to generate a 2D footprint of the roof of the house.  

Open ArcCatalog. Click Add Data and find the new feature class created. By using an image map, zoom in 

to the area of interest. Once it is loaded into ArcMap, right-click on the layer>Select Edit 

Features>Organize Feature Templates> Select the polygon layer>under Create New Templates Wizard 

make sure the polygon is selected and then hit Finish. 

Under Customize tab make sure Editor toolbar is selected. This tool will be used to draw the polygon to 

create the shapefile. Click on the Editor drop-down menu>Start Editing. Disregard the warnings and click 

continue. A Create Features box should appear on the right-side of the screen. Click on your polygon 

layer, under Constructions Tools highlight Polygon. By using the Straight Segment tool on the Editor 

toolbox, trace over the outline of the roof by clicking once on each vertex of the polygon and double-

clicking at the last one. On the Editor toolbox click Editor>Stop Editing>Save Edits. 

 

Figure 8: Creating the shape of the polygon 

Figure 7: Choosing coordinate system under 
New Feature Dataset Figure 6: New Feature class 
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Convert 2D Polygon Shapefile into a Multipatch Shape File 

Now that the polygon shapefile has been created, the next step is to transform it into a multipatch 

shape so that it can be modified using Google SketchUp.  

Open ArcGlobe. ArcGlobe contains three different layer categories: Draped, Floating, and Elevation. 

Information defined under the draped layers is placed on the globe surface (e.g streams), Floating layers 

are set above or below the globe surface (e.g. air pollution concentration) and Elevation layers define 

surfaces of the globe. Since we need the feature class to be placed under the draped layer, under the 

Table of Contents>right-click Globe Layer>Add Data>Add Draped Data. Add the polygon created to 

ArcGlobe by finding and selecting the feature class.  

 

Figure 9: Adding feature class as a draped layer 

Right-click on the polygon>Choose Properties>Globe Extrusion (as shown in Figure 10). Click on Extrude 

features in layer and under the extrusion value input the value by which the building is to be extruded 

by. The units used are meters so when setting the height of the building make sure to take this into 

consideration. The polygon is being extruded now and later it will be modified in the shape of a house. 

 

Figure 10: Extrusion of polygon 
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Figure 11: Polygon shape extruded to desired height 

Figure 11 shows the results from extruding the polygon shape. Under layers properties you can also 

change the display options, for example making the building transparent so that you are able to see the 

base map underneath.  

The next step is to transform the polygon shape feature class to a Multipatch by using “Layer to 3D 

Feature Class” tool. As shown in Figure 12, the tool is found under ArcToolbox>3D Analyst 

Tool>Conversion>Layer 3D to Feature Class. 

 

Figure 12: Layer 3D to Feature Class tool used to transform polygon to mutipatch 

In order for this to work, the feature class has to be in a file geodatabase. The purpose of converting the 

feature class into a multipatch is to give the polygon the volumetric shape needed for the analysis. As 

shown in Figure 13, under Input Feature Layer choose the feature class made, in this case it was name 

Roof. Identify the name and location of the new multipatch under Output Feature Class, in this case it 

was named ROOF_Z. The new multipatch feature class is not shown in the map because it was place 

under the Floating Layer. Right-click on the layer>click on redefine layer>choose Redefined Layer as 

Draped. This will place the multipatch on top of the map, as shown in Figure 14. 
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Figure 13: Defining attributes of Layer 3D to Feature Class 

 

Figure 14: New multipatch feature class 

As shown in Figure 14, the house is in the shape of an extruded polygon. To draw the roof the 

multipatch layer will be extracted to Google SketchUp for modifications. In order to export the shape to 

Google SketchUp the layer must first be converted to a Collada file. The tool needed is found by clicking 

ArcToolbox>Conversion Tools>To Collada>Multipatch to Collada (see Figure 15). This is a type of file that 

can be read by Google SketchUp. 

 

Figure 15: Multipatch to Collada Tool 

Under the Multipatch To Collada window (Figure 16), input the ROOF_Z feature class in Input Multipatch 

Feature. Under Output Collada Folder find a location to save the file and name it. Keeping the Prepend 

Source Name (optional) checked saves the new file as the Use field Name identified by the drop-down 

menu. Uncheck to have the file created as the one identified under the Output field. 
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Figure 16: Defining Multipatch to Collada parameters  

This tool will generate a new file folder with the new collada file inside.  

Use SketchUp To Redefine Building Shape 

Google SketchUp was utilized to make the shape of the roof. This is a free program that can be 

downloaded at http://sketchup.google.com/download/. To import the collada file created, open 

SketchUp>Click on Start using SketchUp>Click on File>Import>find the folder generated by the collada 

tool and click on the .dae file created. Figure 17 shows a picture of the SketchUp program. 

 

Figure 17: Google SketchUp 8 

http://sketchup.google.com/download/
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Figure 18: Collada file imported to Google SketchUp 

Figure 18 shows the imported layer. The necessary modifications to the structure were made by utilizing 

the following tools in the program: Rectangle, Line, Push-Pull, Move, Tape Measure, and Orbit. There 

are many online tutorials that can help in using the program. This author is not very familiar with Google 

SketchUp so the house structure created, shown in Figure 19, is not very detailed. Only the necessary 

adjustments were made to construct the basic structure. Google SketchUp also lets you change the 

texture of the house and make a more realistic design; the drawings can be as detailed and exact as an 

individual can make it. Many 3D buildings found in Google Earth were created using this program. Once 

a building or a structure is created individuals can share their drawings with the online community by 

uploading into Google Earth or ArcGIS. 

 

Figure 19: House structure constructed using Google SketchUp 

Once the drawing is finished, go to File>click on Export>3D Model. Save the new file. 
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Figure 20: Exporting 3D model created in Google SketchUp 

Importing Google SketchUp Model Created Into ArcGlobe 

Now that the new model was created, it needs to be imported back to ArcGlobe to replace the old 

shape. Right-click on the multipatch feature class>Edit Features>Start Editing. On the 3D Editor toolbar 

click on Edit Replacement Tool and then click on the polygon, ROOF_Z  in this case. Once the feature 

class is highlighted then pull-down the 3D Editor menu and select Replace with Model (Figure 21).  

 

Figure 21: Replacing old multipatch feature class with the newly created drawing in Google SketchUp 

Select the SketchUp model created from the opened window (Figure 22). 

 

Figure 22: New house drawing generated in SketchUp 

Shown in Figure 23 is the new drawing that was generated in SketchUp. The old multipatch polygon is 

shown in opaque green and the new drawing is shown in dark green for comparison. The new drawing 

replace the older one perfectly because the drawing created in SketchUp was done using the exact 

measurements identified at the beginning of the report. 
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Figure 23: SketchUp model imported to replace old feature class 

 

Figure 24: Final feature class 

Figure 24 shows the final drawing created using the combination of various programs: ArcCatalog, 

ArcMap, ArcScene, ArcGlobe and Google SketchUp. This report focused on creating a 3D structure from 

beginning to end. Exact measurements were used in creating the shapes in Google SketchUp but exact 

measurements were not added to the feature class in ArcGIS. The next step of this report will focus on 

adding dimensions to the feature class and calculating the amount of water that can be captured. 

Calculating Rainwater Capacity 
After adding the dimensions to the model the total flow was calculated by using the following formula 

provided by Dr. Maidment: 

  
  

     
 

 

q= unit flow per unit width that is traveling down the roof 
i= rainfall intensity, in/hr 
L=length along the roof, ft 
So=slope 
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The water depth along the roof changes as rainfall travels down the roof. A follow-up to this project 
would need to consider this into the analysis.   
 

Table 1: Rainfall intensities for 100-Yr Storm 

 
 

 
Figure 25: Flow to be expected for 100-year storm 

 
 
Rainfall intensities listed in Table 1 were obtained the U.S. Department of Commerce Weather Bureau 
report. Rainfall depths were obtained from isohyetal maps. The results are listed in Table 1 and Figure 
25. The maps for Oahu were small therefore the exact rainfall was approximated as best as possible. The 
mean annual rainfall for the study area is about 29.58 inches. As shown in Figure 26, the study area 
experiences rainfall throughout the year. This makes it an ideal place for rainwater capture. 
 

 
Figure 26: Rainfall information obtained from Rainfall Atlas of Hawai'i 

Time, hr Rainfall, in Intensity in/hr Intensity, ft/sec Length, ft S0 Width, ft Q, cfs

0.5 2.5 5.00 0.000116 16 0.092 51 0.1836

1 3 3.00 0.000069 16 0.092 51 0.1102

2 5 2.50 0.000058 16 0.092 51 0.0918

3 6 2.00 0.000046 16 0.092 51 0.0735

6 8 1.33 0.000031 16 0.092 51 0.0490

12 10 0.83 0.000019 16 0.092 51 0.0306

24 14 0.58 0.000014 16 0.092 51 0.0214
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Conclusion 
The objectives of this project were to develop a 3D model of a structure and determine 

rainwater capacity. My original objective was to come up with a model that could calculate the amount 

of rainfall that could be captured by considering a more realistic representation of how the water depth 

changes as it travels down the roof. The flow was found but more work needs to be done in order to 

accomplish the more realistic way of the water flow.  

Learning how to model 3D data was one of the most useful parts of this project. This class was 

focused on ArcMap, but by doing this project I was also able to learn how to use ArcGlobe. Most of this 

paper focuses on how to begin the analysis from beginning to end, creating a feature class to drawing 

the 3D structure. As detailed in the paper, various programs are needed to create the 3D structure. 

These programs, and others out there, are helping develop a 3D map of the world that can be assessed 

by anyone and used in different parts of the industry and community. It has motivated me to continue 

learning the programs so that I can do future analysis in areas that do not yet have 3D modeling 

structures, outside of the U.S. 

 This project focused on learning how to generate a 3D house model. There is still much more 

work that can be accomplished and researched. A good way to expand this paper would be to continue 

the development of a small residential community and adding the 3D perspective of its geologic 

features. 
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